Are you struggling to setup NetFlow on your Cisco router or other vendor gear? We have a Web page dedicated to helping people find the commands to set up NetFlow, sFlow, IPFIX, JFlow, Netstream, etc.  It is all ‘flow’ technology and we have run into all of them on most hardware.

Some of you may be interested in setting up Cisco NetFlow v9 with support for IPv6. Although Scrutinizer v6 does not support it, we are exploring it for our v7 release. Below I share a few commands for setting IPv6 up on our Cisco router.  Please forgive me for replacing portions of the IP addresses with X.X.

NetFlow and IPv6 setup commands on a Cisco Router:

!
!
interface FastEthernet0/0
ip address 172.X.X.1 255.255.0.0
duplex auto
speed auto
ipv6 address 2001:DB8:BEAC:1::10/64
ipv6 enable
ipv6 flow ingress
ipv6 flow egress
!
interface FastEthernet0/1
ip address 192.168.X.X 255.255.0.0
duplex auto
speed auto
ipv6 address 2001:DB8:DEAD:BEAC:2::10/64
ipv6 enable
ipv6 flow ingress
ipv6 flow egress
!
ip default-gateway 172.16.X.X
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.X.X
ip route X.X.0.0 255.255.0.0 FastEthernet0/0
ip route X.X.0.0 255.255.0.0 FastEthernet0/1
!
ip http server
no ip http secure-server
!
snmp-server community XXXXXXX RO
snmp-server community XXXXXXX RW
ipv6 route 2001:DB8:BEAC::/64 FastEthernet0/0
ipv6 route 2001:DB8:DEAD:BEAC::/64 FastEthernet0/0
!
ipv6 flow-export version 9
ipv6 flow-export destination 10.1.X.X 2055
ipv6 flow-export template options export-stats
ipv6 flow-export template timeout 60
ipv6 flow-export template refresh-rate 10
ipv6 flow-aggregation cache protocol-port
cache timeout active 1
enabled
!
ipv6 flow-aggregation cache source-prefix
export version 9
export destination 172.16.X.X 2057
mask source minimum 64
!
!

Turn on Wireshark and watch the NetFlow packets come in. I’ll have more updates for you on NetFlow and IPv6 as I receive them.  🙂

Mike Patterson author pic

Michael

Michael is one of the Co-founders and the former product manager for Scrutinizer. He enjoys many outdoor winter sports and often takes videos when he is snowmobiling, ice fishing or sledding with his kids. Cold weather and lots of snow make the best winters as far as he is concerned. Prior to starting Somix and Plixer, Mike worked in technical support at Cabletron Systems, acquired his Novell CNE and then moved to the training department for a few years. While in training he finished his Masters in Computer Information Systems from Southern New Hampshire University and then left technical training to pursue a new skill set in Professional Services. In 1998 he left the 'Tron' to start Somix which later became Plixer.

Related

Leave a Reply